Raise Request on Behalf of Customer Not Searching for Users

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

  1. Typing on the Field does not search any available Users/Customers.
  2. The Field is rendered as a "Text Field"
  3. It is not rendered as shown in the documentation "Raising requests on behalf of customers.

Diagnosis

Check if the Agent has the Browse User as in "Managing Global Permissions".

Cause

The Agent does not have the Browser User Global Permission as it is needed to search users using this field

Resolution

  1. Navigate to JIRA Administration > System > Global Permissions.
  2. Add the Browse User permission to the Agent group.

  3. Check if the feature is able to search users based on the ServiceDesk Project Customer List.

Last modified on Oct 31, 2024

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