Request type under email channel are disabled or greyed out
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
While configuring an email channel under Service desk Project, few of the request types are disabled/greyed out with message even though the required fields does exits "A request type is suitable for the email channel when both the Summary and Description fields are visible, and all the other visible fields, if any, are optional. If you want to use tis request type, you need to change its setting to match the criteria
".
Environment
All Jira versions
Diagnosis
- Check if both fields i.e 'Summary' and 'Description' does exists in the Request type
- Compare the requests type that are visible with those that are greyed out with regards to the fields the contain
- Check the values
Cause
- Requests type are considered invalid if there are any invalid records in "AO_54307E_VIEWPORTFIELD" table
- For e.g, in the below screenshot, the custom field was deleted however it still exists in the config table AO_54307E_VIEWPORTFIELD
Solution
- Execute below SQLs to verify/identify the invalid records.
- select "ID",* from "AO_54307E_VIEWPORT" where "KEY"='itsd' // This query needs Project Key as inputs. From the SQL requests, the ID column needs to be noted to be used in the below query
- select "ID","KEY","NAME","INTRO" from "AO_54307E_VIEWPORTFORM" where "VIEWPORT_ID"= <ID obtained from above SQL 1> order by "ID" // Note down ID column from the SQL result. Get all the IDs that are mapped to the problematic request type (greyed out in drop down)
- select "FIELD_ID",* from "AO_54307E_VIEWPORTFIELD" where "FORM_ID" in (<IDs from the above >) // The "FIELD_ID" column needs to be reviewed, check if all the custom fields [customfield_xxxxx] does exists either from UI or from DB.
- select * from customfield c where ID=<ID of the custom field>
- If there does not exists any custom field that are listed in output of SQL 3 i.e "AO_54307E_VIEWPORTFIELD", then you might want to DELETE those records from "AO_54307E_VIEWPORTFIELD" table as those are orphan records.
- Restart Jira.
Note: Ensure you take complete backup of the Database before you DELETE any records.