Request types that are hidden from portal are appearing in the portal
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Sometimes, it happens that customers have only a few request types set to show in the portal and have all others as "Hidden from portal". However the "hidden" request types show up in the drop-down filter for Request Type in the 'Requests' page.
The expectation for most users in this case is that only the request types that are not hidden from the portal, would appear in the 'Request type' drop down.
Request Types shown in the portal:
Hidden request types available in the Request Type drop down filter:
Diagnosis
When a request type is hidden from the portal, it means that customers would not be able to create new tickets using that specific request type. So such hidden request types would not be shown in the 'What can we help you with?' section.
However users would be able to view such hidden request types as options in the 'Request Type' drop down filter on "Requests" section.
This is to ensure that any existing tickets that use that request type could be searched for and displayed. This is not a bug but is intended behavior as explained in the linked (and closed) bug ticket.
- JSDCLOUD-8950Getting issue details... STATUS
However there is also a suggestion ticket raised to have such hidden request types removed from the filter drop down:
- JSDCLOUD-10320Getting issue details... STATUS