Resolving Email Visibility Issues in Jira Cloud REST API Responses

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When using the Jira Cloud REST API endpoints (e.g. Get issue or Get user) to retrieve user information, such as the reporter or assignee, you may encounter a situation where the email address is not included in the API response. This issue is often related to the User email visibility settings in Jira or User email visibility setting in Jira's system general configuration.

Environment

Jira Cloud.

Diagnosis

Email addresses might not be returned in the API response due to User email visibility settings in Jira personal Profile and Visibility settings or User email visibility setting in Jira's system general configuration. Please note that User email visibility setting in Jira's general configuration of Sandboxes is independent of such configuration in the parent production instance.

Difference in API response is presented below:

Email address visibility set to "Only you and admins"
...
"reporter": {
  "self": "https://SITENAME.atlassian.net/rest/api/3/user?accountId=712025%3A14a4cce-32a6-4142-b093-3f1eb3bf4d1",
  "accountId": "712025%3A14a4cce-32a6-4142-b093-3f1eb3bf4d1",
  "avatarUrls": {
    "48x48": "https://example.com/avatar/4.png",
    "24x24": "https://example.com/avatar/4.png",
    "16x16": "https://example.com/avatar/4.png",
    "32x32": "https://example.com/avatar/4.png"
  },
  "displayName": "Test User",
  "active": true,
  "timeZone": "Europe/Warsaw",
  "accountType": "atlassian"
},
...

Email address visibility set to "Anyone"
...
"reporter": {
  "self": "https://SITENAME.atlassian.net/rest/api/3/user?accountId=712025%3A14a4cce-32a6-4142-b093-3f1eb3bf4d1",
  "accountId": "712025%3A14a4cce-32a6-4142-b093-3f1eb3bf4d1",
  "emailAddress": "test_user@example.com",
   "avatarUrls": {
    "48x48": "https://example.com/avatar/4.png",
    "24x24": "https://example.com/avatar/4.png",
    "16x16": "https://example.com/avatar/4.png",
    "32x32": "https://example.com/avatar/4.png"
  }, 
  "displayName": "Test User",
  "active": true,
  "timeZone": "Europe/Warsaw",
  "accountType": "atlassian"
},
...

Cause

The discrepancy between environments can be traced back to:

  1. User email visibility setting in Jira's general configuration - if setting is configured to "Hidden" all email addresses will be hidden in API responses.
  2. User email visibility settings in Jira personal Profile and Visibility settings - if setting is configured to "Only you and admins", user's email address will be hidden in API responses.

Solution

To make sure email addresses are returned in API responses, follow these steps:

  1. Navigate to your Jira instance.
  2. Go to Settings > System.
  3. Select General Configuration.
  4. Click on Edit Settings.
  5. Locate the User email visibility option.
  6. Change the setting to either Public or Logged in users only.
  7. Click Update to save the changes.
  8. Send a new API request to Get issue API endpoint.
  9. Check the response to ensure that the email addresses are now included.

If the email address of the specific user is still not returned, make sure this user updates their profile information:

  1. Have the user log in to their Atlassian account and view the Profile and visibility page: https://id.atlassian.com/manage-profile/profile-and-visibility
  2. Under Contact find
  3. Under Who can see this? select Anyone.
  4. Changes will take effect within five minutes everywhere your profile appears.
  5. Send a new API request to Get issue API endpoint.
  6. Check the response to ensure that the email addresses are now included.

Additional Considerations

  • Profile and Visibility Settings: Ensure that individual user profiles have their email visibility set appropriately. Managed accounts have options such as Only you and admins, Organisation, and Anyone.

  • GDPR Compliance: Be aware that these settings are in place to comply with GDPR regulations, which may restrict email visibility.

For further information, please contact refer to the following Support Documentation:

Last modified on Mar 19, 2025

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