Service Desk Installed, but Not Enabled. Found dependent enabled plugins for plugin...

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This Knowledge Base article was written specifically for the Atlassian Server platform. Due to the Functional differences in Atlassian Cloud, the contents of this article cannot be applied to Atlassian Cloud applications.

This Knowledge Base article was written specifically for the Atlassian Server platform and may be self applied. Atlassian Cloud customers may create a support request referencing this article to have the solution applied on your behalf by Atlassian Support.

Problem

ServiceDesk Application is installed but it is not enabled.


The following appears in the atlassian-jira.log, which shows ServiceDesk tries to load, but due to dependencies on different plugins it fails and disables.

2016-01-21 16:14:59,094 UpmAsynchronousTaskManager:thread-4 INFO <USERNAME> 969x32794x1 1doziyt 210.6.243.42 /rest/plugins/1.0/installed-marketplace [c.a.plugin.manager.DefaultPluginManager] Found dependent enabled plugins for plugin 'com.atlassian.servicedesk.project-ui': [].  Disabling...

Diagnosis

Looking at project administration, we can notice the project type is ServiceDesk, but the project does not have ServiceDesk items and behaviour per image below:

Cause

ServiceDesk Application requires several plugins to load prior to its loading process. Therefore if they fail, ServiceDesk will fail to load as well. 

pocketknife needs to be loaded first and after that client-resourcechaperone and email-processor. This can happen due to disabling plugins on earlier version of JIRA and after upgrade to JIRA 7, it can cause this issue.

Using below query we can figure out if mentioned plugins are disabled or not:

 select * from pluginstate;

If the result is as below:

                     pluginkey                   | pluginenabled
-------------------------------------------------+---------------
 com.atlassian.jira.jira-email-processor-plugin  | false
 com.atlassian.plugins.atlassian-chaperone       | false
 com.atlassian.plugins.atlassian-client-resource | false
 com.atlassian.pocketknife.api.commons.plugin    | false

Resolution

Run below queries to enable the plugins:

  1. update pluginstate set pluginenabled='true' where pluginkey='com.atlassian.pocketknife.api.commons.plugin';
  2. update pluginstate set pluginenabled='true' where pluginkey='com.atlassian.jira.jira-email-processor-plugin';
  3. update pluginstate set pluginenabled='true' where pluginkey='com.atlassian.plugins.atlassian-chaperone';
  4. update pluginstate set pluginenabled='true' where pluginkey='com.atlassian.plugins.atlassian-client-resource';
  5. Restart JIRA after any database changes.
tip/resting Created with Sketch.

If you face any issue on browsing the project please refer to ServiceDesk, Existing Project Fails To Load, 500 error, RuntimeException.

Last modified on Nov 14, 2018

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