Service Management Customers will count towards jira-users license if "Default Group Memberships" is configured
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
In Service Management 2.0 and above with public signup, Customers are added into the certain groups and count towards Jira license. As a result, Service Management Customers are able to login Jira and perform actions based on the permission given to the configured groups.
By default they should not be added into any groups.
Diagnosis
Jira is configured to external user management such as LDAP or Crowd.
Cause
This is an expected behaviour as Default Group Membership option is enabled for Jira to LDAP or Crowd, thus new users will be automatically added into the configured group(s), usually jira-users so they can login.
Workaround
Disable Default Group Membership in LDAP or Crowd.