Service Management project's navigation bar shows "Unable to render element due to an error" even though required upgrade tasks are fulfilled
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
After upgrading to Jira Service Management 3.2.x, observe the problem below while browsing a Service Management project. The project navigation bar will not render properly with message Unable to render element due to an error on top of the bar:
The following appears in the atlassian-jira.log:
*********************************************************************************
Jira ServiceDesk v3.2.0-069 #DevVersion built 2016-09-20T07:49:12.702+07:00 - Starting sync upgrade task: SyncUpgradeTaskMigrateAgentPermission
*********************************************************************************
2016-10-11 19:57:13,676 Jira-Bootstrap ERROR [atlassian.servicedesk.lifecycle] sd.upgrade.task.error.failure.message.with.exception.message
java.lang.NullPointerException
...
at com.atlassian.jira.scheme.AbstractSchemeManager.getProjects(AbstractSchemeManager.java:481)
...
at com.sun.proxy.$Proxy3085.getProjects(Unknown Source)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.isPermissionSchemeUsedByServiceDeskProject(SyncUpgradeTaskMigrateAgentPermission.java:182)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.getPermissionSchemesUsedByServiceDesk(SyncUpgradeTaskMigrateAgentPermission.java:173)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.performUpgradeAgentPermission(SyncUpgradeTaskMigrateAgentPermission.java:128)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.doUpgrade(SyncUpgradeTaskMigrateAgentPermission.java:86)
...
*********************************************************************************
Jira ServiceDesk v3.2.0-069 #DevVersion built 2016-09-20T07:49:12.702+07:00 - Startup has failed with an unexpected problem. It is unsafe to proceed.
*********************************************************************************
OR
2016-12-13 18:22:59,034 http-nio-8724-exec-4 ERROR admin 1102x1031x1 pjpbcm 0:0:0:0:0:0:0:1 /plugins/servlet/project-config/KEY/summary [c.a.p.webresource.assembler.DefaultWebResourceAssembler] Error generating bigpipe content for 'sidebar-id': java.lang.RuntimeException: This is a Service Management project, but we were unable to load the Service Management project context. It may be possible to fix this error by converting this project to a different project type, and then converting it back to Service Management.
Diagnosis
If this is a direct upgrade from Jira 6.x with SD 1.x or 2.x to Jira 7.2.x with SD 3.2.x, please check this KB article instead, because the required upgrade tasks have been missed:
However, if the required upgrade tasks have been fulfilled i.e. Jira has been upgraded to 7.0.x/3.0.x or 7.1.x/3.1.x before being upgraded to 7.2.x/3.2.x, then the following Causes and Resolutions apply.
Cause
Cause 1
According to the Error message:
at com.atlassian.jira.scheme.AbstractSchemeManager.getProjects(AbstractSchemeManager.java:481)
...
at com.sun.proxy.$Proxy3085.getProjects(Unknown Source)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.isPermissionSchemeUsedByServiceDeskProject(SyncUpgradeTaskMigrateAgentPermission.java:182)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.getPermissionSchemesUsedByServiceDesk(SyncUpgradeTaskMigrateAgentPermission.java:173)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.performUpgradeAgentPermission(SyncUpgradeTaskMigrateAgentPermission.java:128)
at com.atlassian.servicedesk.bootstrap.upgrade.tasks.SyncUpgradeTaskMigrateAgentPermission.doUpgrade(SyncUpgradeTaskMigrateAgentPermission.java:86)
...
Jira is trying to find associations between Projects and Schemes, however gets one or more project IDs that do not exist any more.
Cause 2
According to the Error message:
2016-12-13 18:22:59,034 http-nio-8724-exec-4 ERROR admin 1102x1031x1 pjpbcm 0:0:0:0:0:0:0:1 /plugins/servlet/project-config/KEY/summary [c.a.p.webresource.assembler.DefaultWebResourceAssembler] Error generating bigpipe content for 'sidebar-id': java.lang.RuntimeException: This is a Service Management project, but we were unable to load the Service Management project context. It may be possible to fix this error by converting this project to a different project type, and then converting it back to Service Management.
The Service Management context of the project fails to be loaded.
Resolution
For Cause 1
- Shut down Jira
Run the following SQL query to find those project IDs that do not match any existing projects:
select * from nodeassociation where source_node_entity = 'Project' and association_type = 'ProjectScheme' and source_node_id not in (select id from project);
If there are entries returned, they should be causing the problem. Back up the database then run this SQL query to delete them:
delete from nodeassociation where source_node_entity = 'Project' and association_type = 'ProjectScheme' and source_node_id not in (select id from project);
- Restart Jira
For Cause 2
Change the Project Type of the project from Service Management to Business and then change it back to Service Management to refresh the Service Management context of the project.