Some Jira pages fail to render or some actions fail to complete with the error ERR_HTTP2_SERVER_REFUSED_STREAM

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

   

Summary

Some (or all) Jira pages fail to render or some actions fail to complete with the error ERR_HTTP2_SERVER_REFUSED_STREAM thrown in the browser. Some example of impacted pages or actions are listed below:

  • the Jira Dashboard page does not render at all
  • when accessing the page ⚙ > Manage Apps page, the page renders partially, but add-ons are not loaded
  • when trying to translate a status via the page ⚙ > Issues > Statuses > Translate Statuses (/secure/admin/ViewTranslations.jspa), the error ERR_HTTP2_SERVER_REFUSED_STREAM is thrown when clicking on the Update button after adding a translation

(warning) Note that the list above is not exhaustive.

Environment

Any Jira Server and Data Center version

Diagnosis

  • The message "the website is not available" is thrown in the browser along with the error ERR_HTTP2_SERVER_REFUSED_STREAM
  • When collecting a HAR file while replicating the error, we can see the same error ERR_HTTP2_SERVER_REFUSED_STREAM along with the HTTP response code 0 associated with the URL that triggered the error (an example of impacted URL can be /secure/admin/ViewTranslations.jspa):

            "response": {
              "status": 0,
              "statusText": "",
              "httpVersion": "",
              "headers": [],
              "cookies": [],
              "content": {
                "size": 0,
                "mimeType": "x-unknown"
              },
              "redirectURL": "",
              "headersSize": -1,
              "bodySize": -1,
              "_transferSize": 0,
              "_error": "net::ERR_HTTP2_SERVER_REFUSED_STREAM"
            },
  • when searching for the URL that triggered the error in the HAR file (for example /secure/admin/ViewTranslations.jspa) in the Tomcat Access logs (located in <JIRA_INSTALL_DIR>/logs/), we can see that this URL is missing from the logs.
    • This indicate that the HTTP request never reached the Jira applications, which means that something between the browser and the Jira application on the network layer blocked that URL and triggered the error thrown in the browser

Cause

Something on the network layer between the browser and the Jira application is blocking an HTTP request. As a result, that HTTP request never reached the Jira application. So far, 2 potential root causes have been identified (listed below):

Root cause 1

If Jira is configured to run behind a reverse proxy or load balancer, then it is possible that the reverse proxy server is causing the issue:

  • when using Nginx as a reverse proxy server, having http2 enabled can cause the error ERR_HTTP2_SERVER_REFUSED_STREAM, as explained in this stackoverflow discussion
  • when using HAProxy as a reverse proxy server, using LibreSSL can cause the error ERR_HTTP2_SERVER_REFUSED_STREAM, as explained in this github discussion

To confirm that the problem is coming from the proxy side, try to access Jira while bypassing the proxy configuration as per this documentation. If the problem goes away while bypassing the proxy configuration, then it is an indication that the proxy is causing the issue.

Root cause 2

An incorrect firewall configuration issue can cause the error ERR_HTTP2_SERVER_REFUSED_STREAM.

Solution

For Root cause 1

The resolution depends on the situation:

  • If you are using an Nginx proxy server:
  • If you are using an HAProxy proxy server, try to switch from LibreSSL to OpenSSL, as per this github discussion
  • If you are using a different proxy server, of if none of the suggestion above helped, please reach out to your proxy server administrator for further help.

For Root cause 2

Reach out to your Firewall administrator for assistance, so that they can check on the Firewall side if any HTTP request that was meant for the Jira application is blocked.

Last modified on Sep 7, 2021

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