Some users are not appearing in any user picker field when raising a request from the Customer Portal
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When trying to add users to any user picker field (single user, multi user, approver field...) in the customer portal, some users cannot be found and do not appear in the dropdown, even though they have access to the portal.
When searching for the user, the message "No results found is displayed":
Environment
Jira Service Management Server/Data Center on any version from 3.0.0.
Diagnosis
- For the diagnosis part, we will assume that:
- julien is the user who is raising a request on the customer portal
- julien3 is the user who cannot be found in any user picker field
- Go to the portal permission configuration in the Service Management project, via the page Project Settings > Customer Permissions.
- Take a look at the setting Who can customers share requests with? to see if it is set to Other customers in their organization
- Take a look at the setting Who can customers share requests with? to see if it is set to Other customers in their organization
- In the same project, go the Customers page. Check if the user who is unable to search for other users (user julien in the example above) on the customer portal is part of an organization
- If this user is not part of any organization, this KB article is relevant and you can move on to the Cause and Solution sections
- If this user part of an organization, check if the user that cannot be found in the request creation form (user julien3 in the example above) is missing from that organization. If that's the case, then this KB article is relevant and you can move on to the Cause and Solution sections
Cause
The setting Who can customers share requests with? in the Customer Permissions page impacts the way user picker fields behave on the Customer Portal, which includes (but is not limited to) the fields listed below:
- Single user picker
- Multi user picker
- Approvers
- Request Participants
Let's assume that:
- The user User 1 is raising a new request from the Customer Portal
- The users User 1 and User 2 are not part of the same Organization (not to be confused with Jira Groups. You can find more information about organizations in this documentation)
In this case, if the setting Who can customers share requests with? is set to Other customers in their organizations, User 1 will not be able to search for User 2 in any user picker field.
Solution
There are a few solutions for this issue.
Solution 1
Set Who can customers share requests with? to Any customer or organization, by searching in this project.
The downside of choosing such option is the fact that any customer who has access to the portal will be able to search for any other customer via user picker fields (which could be a potential security issue).
Solution 2
Create a new Organization in the project, and add both users in it.