Standalone version of Assets is not accessible after upgrading Jira Software to version 9.12 and above

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading Jira Software from version 8.15 or 9.4 to Jira Software 9.12 and above, the Assets drop down menu is not accessible in the upgraded instance.

Attempting to access standalone versions of the Assets plugin at Atlassian Marketplace results in "We're experiencing an issue" error

Environment

Jira Software 8.x or 9.4 and below with Standalone version of Assets plugin, upgraded to Jira Software 9.12 and above

Diagnostics

In addition to what's described in the summary section above, it might help to run the following SQL query to see if your instance had Assets only license:

SELECT * 
FROM   propertytext pt 
       JOIN propertyentry pe 
         ON pt.id = pe.id 
WHERE  property_key like '%License%' and propertyvalue like 'first few characters of your Assets only license'; 

To find the 'first few characters of your Assets only license' - please locate your Assets license under your account in our portal - my.atlassian.com, then simply copy paste a few characters from the beginning of the license code to the 'first few characters of your Assets only license' section of the query above. If the query returns a match - then it means that your Assets plugin was licensed as as standalone version and it won't be possible to simply upgrade the add-on, you'd need to perform the steps from Solution section below to resolve the issue

Cause

Cause 1: Most probable cause is that as Support for Server products ended on February 15, 2024, standalone version of the Assets plugin is no longer available for download or upgrade. The assets plugin is now bundled with Jira Service Management only as of Jira 9.12 onwards.

Cause 2: Less likely but it is possible that some upgrade tasks failed to complete during the upgrade. If the solution below doesn't fix the issue, please check this KB article for further details

Solution

If the license for Assets plugin in your Jira Instance is still valid, you can install Jira Service Management on the instance (from either the marketplace or direct .obr upload) and it should re-enable the plugin and it will be functional until the subscription expiry date.

Once the subscription expires, if you’re on Jira Software Data Center version 8.15 or higher, you’ll need a Data Center subscription to Jira Service Management on the same instance to use the apps with Jira Software Data Center (minimal license for Jira Service Management is sufficient to enable Insight for all of your users). If you’re on Jira Software Data Center version 8.14 and below, you can switch to using the free version of the apps as described in scenario 2.


Reference:

https://confluence.atlassian.com/jirasoftware/jira-software-8-15-x-upgrade-notes-1041828754.html#JiraSoftware8.15.xupgradenotes-insight:~:text=If%20you%E2%80%99ve%20purchased,in%20scenario%202


Last modified on Jul 9, 2024

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