The Request Type dropdown in "Edit Request Type" action in automation rules is missing some Request Types

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

   

Summary

Some of the Customer Request Types are missing and therefore are not be selectable in the Edit Request Type action when configuring a Jira Service Management automation rule (via the page Project Settings > Automation). When typing the exact name of such Request Type, the following error is displayed in the UI:

Please select a valid request type

Environment

Jira Service Management (JSM) 4.0.0 and any higher version.

Cause

Root Cause 1 - The missing Customer Request Types are coming from a different project

Customer Request Types only exist in the context of the project where they were created. Therefore, if a Request Type was created in "Project 1", then it will not be found when configuring an automation rule in "Project 2".

Root Cause 2 - There are more than 100 Customer Request Types configured in the project and we are hitting a bug

If there are more than 100 Customer Request Types configured in a Service Management project, then due to the bug mentioned below, only the first 100 Request Types will be selectable in the automation rule.

JSDSERVER-10976 - Getting issue details... STATUS


Diagnosis

Diagnosis for Root Cause 1

Check if the Customer Request Types that can't be selected in the automation rule are coming from a different project. If that's the case, then this root cause is relevant.

Diagnosis for Root Cause 2

Go to the page Project Settings > Request Types and check how many Request Types are configured there. If there are more than 100, and if only the recently created Request Types can't be selected in the automation rule, then this root cause is relevant.

Solution

Solution for Root Cause 1

Make sure that the missing Request Types are created within the same project where the automation is configured.

Solution for Root Cause 2

Since the bug JSDSERVER-10976 was fixed in the JSM versions 4.13.20, 4.20.8, 5.0.0, the best solution is to upgrade the JSM application to any of these versions.

If upgrading is not an option for now, there is unfortunately no ideal workaround. The only options are to:

  • either ensure that there is not more than 100 Request Types configured within the same project
  • or use an automation module coming from an add-on which does not have such limit. Some examples of such add-ons are listed below ((warning) Note that these add-ons are paid add-ons):




Last modified on Sep 2, 2022

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