Troubleshooting and Support Tools missing

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The Troubleshooting and Support Tools option is missing on the left menu from the System page:

Diagnosis

The "Troubleshooting and Support Tools" is an embedded system plugin installed and enabled by default.

Check the plugin state following the steps below: 

  1. In the top navigation bar click on  > Manage Apps;
  2. On the left menu click on Manage Apps;
  3. In the Manage Apps screen on the Filter visible apps field insert Troubleshooting;
  4. On the dropdown menu that shows "User-installed", change it to "All apps";
  5. Locate the Atlassian Troubleshooting and Support Tools plugin under the System apps section and expand it;

Possible Causes

There are a few possible known causes that can make the "Troubleshooting and Support tools" unavailable in the interface: 

  1. The entire plugin or one of its modules may be disabled;
  2. The plugin may be missing in Jira;
  3. The user does not have the system administrator global permission

Resolution

For Cause 1 - Plugin is Disabled

  1. In the top navigation bar click on  > Manage Apps;
  2. On the left menu click on Manage Apps;
  3. In the Manage Apps screen on the Filter visible apps field insert Troubleshooting;
  4. On the dropdown menu that shows "User-installed", change it to "All apps";
  5. Locate the Atlassian Troubleshooting and Support Tools plugin under the System apps section and expand it;
  6. Ensure that the plugin is enabled together with all its modules;


For Cause 2 - Plugin is missing

  1. Download the Troubleshooting and Support - Jira plugin from the Atlassian Marketplace (This is exactly the same embedded plugin provided with Jira)
  2. In the top navigation bar click on  > Manage Apps;
  3. On the left menu click on Manage Apps;
  4. In the Manage Apps screen click on the Upload app button; 
  5. In the Upload app pop up screen click on Choose File and select the downloaded plugin file;
  6. Click on the Upload button. 

For Cause 3 - Missing permission

  1. Make sure the user with which you are logged in has the system administrator global permission.


Last modified on Jul 19, 2023

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