Troubleshooting Jira Service Management license issues

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Jira Service Management licenses are all occupied, despite that there are less users in the user group associated to the Jira Service Management application access.

Diagnosis

Diagnostic Steps

  • Restart Jira application

  • Refresh the license cache by remove or replace the existing JSD license with evaluation license and switched back to the Commercial license

  • Jira Administration >> Applications >> Versions & licenses: Verify the user group(s) that associate to the Jira Service Management application access.

  • Compare the results of following SQL queries to identify the discrepancies:

    • Run the following SQL query to identify the active users that are holding up the license count:

      SELECT DISTINCT u.lower_user_name, d.directory_name, m.parent_name
      FROM   cwd_user u
             JOIN cwd_membership m
               ON u.id = m.child_id
                  AND u.directory_id = m.directory_id
             JOIN licenserolesgroup lrg
               ON Lower(m.parent_name) = Lower(lrg.group_id)
             JOIN cwd_directory d
               ON m.directory_id = d.id
      WHERE d.active = '1'
             AND u.active = '1'
      	AND license_role_name = 'jira-servicedesk';
    • Run the following SQL query to identify the users in the user group(s) that associate to the Jira Service Management application access:

      SELECT * FROM cwd_user u
      JOIN cwd_membership m
      ON u.id = m.child_id
      WHERE m.lower_parent_name='jira-servicedesk-users';
  • Gather relevant data to troubleshoot the license issue:

    • Jira Administration >> System >> Logging and profiling: Click on 'Configure logging level for another package' and add com.atlassian.jira.application*package with DEBUG logging level

      With the debugging package, we expect the getUserCountCurrentValue and Count application users messages be logged and find out how the count is registered.

    • Jira Administration >> Applications >> Versions & licenses: Click on the '(xx agents) xx used' link

    • Share the latest support.zip with Support

Cause

There was a discrepancy between the users that hold the JSD license and users in the user group. The users were from external LDAP and problematic entries were relate to nested group.

Resolution

To rectify this, perform the following steps:

  1. Login with local Jira System Administrators

  2. Jira Administration >> User management >> User Directories: Edit the problematic user directory, checked 'Enable Nested Groups' option. Save and Test.

  3. Synchronise the user directory

  4. Jira Administration >> User management >> User Directories: Edit the problematic user directory, uncheck 'Enable Nested Groups' option. Save and Test.

  5. Synchronise the user directory

  6. Jira Administration >> Applications >> Versions & licenses: Check if the license count is back to the correct number.

Last modified on Nov 6, 2024

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