Trying to view a Project in JIRA throws java.lang.NumberFormatException: null
Problem
When trying to get in one of the projects in the project list, it fails with the following stack trace:
java.lang.NumberFormatException: null
at java.lang.Long.parseLong(Unknown Source)
at java.lang.Long.valueOf(Unknown Source)
at com.atlassian.jira.plugin.issuenav.service.issuetable.IssueDocumentAndIdCollector.addMatch(IssueDocumentAndIdCollector.java:208)
at com.atlassian.jira.plugin.issuenav.service.issuetable.IssueDocumentAndIdCollector.computeResult(IssueDocumentAndIdCollector.java:186)
at com.atlassian.jira.plugin.issuenav.service.issuetable.AbstractIssueTableCreator.executeNormalSearch(AbstractIssueTableCreator.java:236)
at com.atlassian.jira.plugin.issuenav.service.issuetable.AbstractIssueTableCreator.create(AbstractIssueTableCreator.java:198)
at com.atlassian.jira.plugin.issuenav.service.issuetable.DefaultIssueTableService.createIssueTableFromCreator(DefaultIssueTableService.java:165)
at com.atlassian.jira.plugin.issuenav.service.issuetable.DefaultIssueTableService.getIssueTable(DefaultIssueTableService.java:279)
at com.atlassian.jira.plugin.issuenav.service.issuetable.DefaultIssueTableService.getIssueTableFromFilterWithJql(DefaultIssueTableService.java:130)
at com.atlassian.jira.plugin.issuenav.IssueNavAction.performSearch(IssueNavAction.java:1161)
at com.atlassian.jira.plugin.issuenav.IssueNavAction.doNav(IssueNavAction.java:360)
at com.atlassian.jira.plugin.issuenav.IssueNavAction.doDefault(IssueNavAction.java:244)
at webwork.util.InjectionUtils$DefaultInjectionImpl.invoke(InjectionUtils.java:70)
at webwork.util.InjectionUtils.invoke(InjectionUtils.java:56)
Cause
This happens because JIRA expects a number value when loading the page, but no value is returned from the indexes. This is most likely to happen if the search indexes are corrupt.
For example, this may happen if JIRA hit the limit of open files allowed, as described on Too many open files error in Jira server.
Resolution
Trigger a full re-index in JIRA:
- If this problem was caused by the Too Many Open Files error, please follow Too many open files error in Jira server before proceeding.
- Browse to Administration > System > Indexing,
- Trigger Lock JIRA and Rebuild the index to fully reindex JIRA.
During the reindex operation JIRA cannot be accessed. Depending on the size of the instance this operation may take a while, so if needed please run this off business hours.