Unable to open attachments on internet explorer over HTTPS
Diagnosis
When trying to download or open an attachment on Internet Explorer while accessing a JIRA application through HTTPS, users will get error messages similar to the ones below:
Opening an attachment:
Could not open 'https://jiraaddress.com/secure/attachment/12729/My Presentation.ppt'.
Saving the File:
Unable to download My%20Presentation.ppt from jiraaddress.com. Unable to open this Internet site. The requested site is either unavailable or cannot be found. Please try again later.
Additionally, users may be facing problems when seeing notification emails on Outlook as emails don't display images as shown below:
Cause
This problems happen due to cache control headers enabled on the browser configuration. Basically, this is a known Internet Explorer bug and is addressed by Microsoft here (instructions for IE7 and IE8 are near the bottom of the page):
On IE8 and IE9 this can also happen if the option Do not save encrypted pages to disk is enabled. You can find further instruction in these links:
- IE9: Error message when you download files by using Internet Explorer 9 from secure websites: "<filename> couldn’t be downloaded"
- IE8: Internet Explorer file downloads over SSL do not work with the cache control headers. There is a Hotfix availablel for IE8. You may need to install it to solve this problem.
Workaround
There are two possible workaround for this issue, which are:
Adding the following line to $JIRA-Install
/conf/context.xml
seems to resolve this problem:<Valve className="org.apache.catalina.authenticator.BasicAuthenticator" disableProxyCaching="false" />
It's also possible to work around this behavior by removing HTTPS for attachment download (refer to Redirecting certain pages to HTTPS).