Unable to set Issue Type when creating/editing issues in Jira server

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Issue

It is not possible to change the issue type of a Jira issue. The following symptoms can be observed:

  • On the "view issue" page, when hovering over the value of the issue type, there is no pencil/edit button
  • On the "edit issue" page, the issue type cannot be edited either, and the following message is displayed underneath it

    There are no issue types with compatible field configuration and/or workflow associations. The issue type can only be changed by moving this issue.



Cause

  1. It is possible that there is a different 'Field Configuration' set for different Issue types. Eg. There could be hidden Custom Fields on a particular Field configuration which are not available on the Field configuration for another Issue Type. In that case, JIRA would not allow editing the issue and/or switching to another Issue Type.
  2. It could also be that there are different workflow steps associated with different Issue Types. Eg. when you create an Issue Type 'Bug', with a status 'New', which may not be recognized by the workflow for another Issue type 'Task'. This also explains why JIRA does not allow switching Issue Type considering the new issue status and mapping of fields/statuses. 
  3. Jira only allows editing the Issue Type of an issue if the workflow and field configurations are the same.

Workarounds

  • Option 1 - Use the "Move" action instead of the "Edit" action by clicking on More > Move:

  • Option 2 - Update the Field configuration for the related Issue Types and have the same workflows associated with them. This way, it will become possible to change the Issue Type of an issue using the Edit functionality instead of the Move functionality.
  • Option 3 - Remove the field "Issue Type" from your Edit screen configuration.

As a side note you might be able to fix the issue by referring to How To Remove the Message 'Some issue types are unavailable due to incompatible field configuration and/or workflow associations.' from Edit Issue Screen, but it can be a fix for other languages as the mapping to string are different for other languages. 

Last modified on Aug 22, 2023

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