Update License type for Jira instances that have both Jira Software and Jira Service Management

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Attempts to update the license are failing with the message "The license does not match the type of Jira currently licensed."


Cause

This kind of message shows up when there are licenses for Jira Software and Jira Service Management on the same instance. When attempting to change the type of license for one product, this clashes with the type of license for the other product.

Solution

The license for one of the 2 products will need to be temporarily removed to avoid the error and successfully change the type of license. After updating one, the new license for the other product can be used.

  1. Copy and paste the existing licenses of JSM and Jira Software to text file to back them up and have them handy in case the method doesn't work.
  2. Click the trash bin button of JIRA Service Desk License key
  3. Make sure that the box is NOT TICKED for "Also remove my JIRA Service Desk configuration". If the box is ticked, the functionalities of your JSM projects may be affected. 
  4. Click Remove. This will temporarily remove the license for Jira Service Desk, and will temporarily halt JSM specific functionalities of JSM projects.
  5. Update the license of Jira Software License key to the newer key.
  6. Once updated, put in the new license key of Jira Service Service Desk.




Last modified on Oct 20, 2022

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