Updating the Responder field with Automation

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When working with incident management, you may want to automatically update the responder field during specific events such as transitions, approvals, and so on.

Environment

Jira Service Management Cloud

Diagnosis

The responder field is not available when updating automation components such as edit issue.

Cause

Because the responder field is a unique system field that pulls data directly from Opsgenie, the automation components do not yet support it.

Solution

You can use the advanced field editing feature using JSON to workaround this with the following JSON structure:

{
    "update": {
        "Responders": [
            {
                "add": [
                    {
                        "ari": "ari:cloud:opsgenie:<cloud_id>:team/<team_id>",
                        "type": "team"
                    },
                    {
                        "ari": "ari:cloud:opsgenie:<cloud_id>:user/<account_id>",
                        "type": "user"
                    }
                ]
            }
        ]
    }
}
tip/resting Created with Sketch.

You can replace add with remove to remove existing values from the field.

Last modified on Nov 28, 2022

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