Updating the Responder field with Automation
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When working with incident management, you may want to automatically update the responder field during specific events such as transitions, approvals, and so on.
Environment
Jira Service Management Cloud
Diagnosis
The responder field is not available when updating automation components such as edit issue.
Cause
Because the responder field is a unique system field that pulls data directly from Opsgenie, the automation components do not yet support it.
Solution
You can use the advanced field editing feature using JSON to workaround this with the following JSON structure:
{
"update": {
"Responders": [
{
"add": [
{
"ari": "ari:cloud:opsgenie:<cloud_id>:team/<team_id>",
"type": "team"
},
{
"ari": "ari:cloud:identity::user/<account_id>",
"type": "user"
}
]
}
]
}
}
<cloud_id> :
The easy way to get the cloud id is to go to https://<instance>.atlassian.net/admin/jira-service-desk/portal-only-customers. You will get the Cloud id in the URL (e.g.: https://admin.atlassian.com/s/<cloud_id>/jira-service-desk/portal-only-customers)<team_id> :
Available in the URL of the Team's page on Opsgenie (e.g.: https://<instance>.app.opsgenie.com/teams/dashboard/<team_id>/main)<account_id> :
Available in the URL of the User's account page on the Administration hub (e.g.: https://admin.atlassian.com/o/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/users/<account_id> or https://admin.atlassian.com/s/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/users/<account_id>)
You can replace add with remove to remove existing values from the field.