Upgrading from Jira 7.x to Jira 8.5 results in missing database tables and columns

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Problem 

Upgrading from Jira version 7.x to Jira 8.5 might fail with the following exception in the atlassian-jira.log file

com.atlassian.cache.CacheException: java.lang.IllegalArgumentException: [GenericEntity.get] "archived" is not a field of Issue
com.atlassian.cache.CacheException: java.lang.IllegalArgumentException: [GenericEntity.get] 

This has been reported to happen on Server only. 

Cause

The issue might have been caused by using the installer to perform this major upgrade. 
Bug report: JRASERVER-70101: Upgrading Jira from 7.X to 8.4.2 causes tables and columns to not be created

Solution

Jira 8.0 introduced major platform changes as described in Preparing for Jira 8.0. That is why when upgrading from Jira 7.x to Jira 8.5 we advise the manual upgrade method. Additionally, because of the number of changes introduced between the Long Term Support releases versions of Jira, we ask users to refer to our special Long Term Support release upgrade guide when upgrading to Jira 8.5. 

For more information, see Jira 8.5 Long Term Support release upgrade guide


Last modified on Aug 13, 2021

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