User Automatically Become an Agent

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Platform Notice: Server, Data Center, and Cloud By Request - This article was written for the Atlassian server and data center platforms but may also be useful for Atlassian Cloud customers. If completing instructions in this article would help you, please contact Atlassian Support and mention it.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

  1. While the user is not being assigned as an Agent from Service Management Menu > Manage Agent, the user is automatically assigned as an Agent for a specific Project.
  2. From the Manage Agents the user is unable to be remove as an Agent.

Diagnosis

Take note of the Project Permission Scheme for the Roles, Groups and User that have the permissions below:

  • Browse Project
  • Edit Issue

Cause

Due to the user have the permission of both permission above, the user would be considered as an Agent.

Workaround

  1. Go to the Affected Project Permission Scheme on Jira Side.
  2. Remove the Group, Roles or User that is related to the User on the Permission Scheme.
  3. Else, if it is set to only Roles, remove the user from that Roles via Project Administration Scheme > Roles
  4. Check on the Manage Agents page to see if the User is the agent of that project.
Last modified on Nov 23, 2020

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