User with administrator permissions is unable to edit a custom field to add options under a Request Form in JIRA Service Management

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

A user who is a project admin or a user with administrator permissions is unable to edit a field added to a Request Form in order to edit the options/reorder existing options or add more options.

The field is not editable and the message "You can't change this option" is shown as seen below:

New values also cannot be added as the option is grayed out and the message "You can't add an option" is shown as seen below:


Cause

The user is trying to edit a custom field, which has been added to the Request Form. The options that are seen in the Request Form are the values that have been added to the custom field. 

This is expected and even an admin user cannot edit the custom field from the Request Form to add new options. 

Solution

The custom field needs to be edited to add new options and then those new values would show up in the Request Form. This can be done as explained below:

  • Select Cog Icon > Issues.
  • Under FIELDS, click Custom fields.
  • Search for the specific custom field and click  > Contexts and default value > Edit Options

  • Now, new values can be added or existing values can be modified/reordered as shown below:

The new value added earlier would now be reflected in the Request Form as also seen below:


Reference:




Last modified on May 5, 2023

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