View in Issue Navigator link from Test Sessions is not displaying issues
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When viewing a Test Session, the link to "View in Issue Navigator" links to a search without any issues listed, although the Test session contains issues.
Diagnosis
Diagnostic Steps
- Navigate to the test session
- verify "Issues Raised" list displays issues
- Clicking the eye <o> button at the top right of the list "View in Issue Navigator" renders a Search page with a search similar to: "cf[10013] = 10016"
- No issues are listed
Cause
The "Raised During" custom field is hidden on the Field Configuration.
JIRA search results ignore hidden fields so no issues are listed.
Resolution
Follow the instructions on Hiding or showing a field to set the field "Raised During" to 'show' in the Field Configuration.
Reindex JIRA