Watchers on Issue not Receiving Notifications After Comments
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Symptoms include inconsistent notifications being sent. SMTP server can be setup correctly with permissions correctly configured. After adding a watcher to an issue, adding a comment will not generate a notification to the watcher.
Diagnosis
This has only been known to occur on systems using a MS SQL database.
Cause
During system configuration changes (upgrades, migrations), if the database schema name is changed or empty, it can cause inconsistencies in the database and cause it to not be updated correctly. This can cause notifications to not send to watchers.
Resolution
To correct this issue, please refer to Incorrect MS SQL Schema Used to correct the schema name.