Data pipeline export fails but the UI indicates it is in progress
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When exporting data using the data pipeline API in Jira or Confluence, the export fails, but the application UI still indicates that the export is still in progress.
Cause
This can happen if the node running the data export process fails unexpectedly.
Resolution
You will need to manually mark the export as CANCELLED
, and try again.
To mark the export as cancelled, make a DELETE
request, which will release the process from any lock, allowing you to kick off another data export.
For more information on the REST methods available, see: