JCMA pre-check error: "Jira Software is not available on your cloud site"
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Check what to do when your Jira Cloud Migration Assistant (JCMA) preflight checks fail with "Jira Software is not available on your cloud site".
Overview
A Jira migration gets blocked due to one of the following errors in JCMA:
Jira Software is not available on your cloud site.
Jira Work Management is not available on your cloud site.
Jira Service Management is not available on your cloud site.
None of the Jira projects being migrated belong to the Jira product mentioned in the error message (e.g., only Jira Work Management projects are being migrated, but the error message states that Jira Software is not available on the destination cloud site).
Cause
Possible root causes:
- Some scoped groups have access to the Jira product that is missing on the destination cloud site.
- A project was created as a Jira Software project and then converted into a Jira Work Management project afterward.
The internal table licenserolesgroup
stores the links between the groups and the Atlassian products they can access.
The following SQL statements can be executed on the source Jira Server/Data Center instance to check if any of the scoped groups have access to the Jira product that is missing on the destination cloud site:
Missing Jira product | SQL statement |
---|---|
Jira Work Management |
|
Jira Service Management |
|
Jira Software |
|
If scoped groups have access to Jira products that are missing on the destination cloud site, then the affected groups must be adjusted accordingly.
Solution
Possible solutions:
- Install the missing Jira product on the destination cloud site.
- Revoke the access to the missing Jira product from the affected groups on the source Jira Server/Data Center instance.
- Delete the incorrect group role permission (entry from the table
licenserolesgroup
) from the source Jira Server/Data Center instance.