G Suite sync fails with Unexpected error and "Your userbase might be out of date"
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
G Suite synchronization does not run anymore. When synced manually, it displays "Unexpected error. If synchronization fails again, contact Atlassian Support".
Diagnosis
- Check if the users from both domains(if the customer is renaming a user from one domain to another domain) are verified and if yes, then check if both these accounts can be seen under "managed accounts".
- The renaming will fail in Jira in case if both these email address is created in Jira already.
- You can find the Splunk query returning 409 status with an account already exists error.
- If the customer renamed the user from A to B at Google console/Gsuite end. Then these 2 accounts can be found in the managed account section at the Org level. Sometimes, you will not be able to get results in search so update the AAID in the URL to search for the user.
Cause
- If the target email already exists in Jira, then the renaming will be successful on the GSuite side, however, in Jira there will be 2 accounts created for each email address.
- Due to 2 accounts, the renaming will not be possible in Jira resulting in GSync error "Your userbase might be out of date"
Solution
- Check if the users from both domains are verified and if yes, then check if both these accounts can be seen under "managed accounts".
- If the customer renamed the user from A to B. Then these 2 accounts can be found in the managed account section. Sometimes, you will not be able to get results in search so update the AAID in the URL to search for the user.
- Open the second/newly added account as it does not hold any data. As the account is managed, edit the email address and change to a dummy address and checkmark to save the changes.
- Navigate to GSuite settings at the Org level - https://admin.atlassian.com/o/<ORGID>/gsuite
- Click on Sync now
- Now check the old user who was renamed in GSuite. The user sync will be successful resulting in the changes at the GSuite end ie. user's email address will be changed from A to B.
- You can now delete the duplicate account which you changed to a dummy email address.
Last modified on Jan 22, 2021
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