"Unknown fields set during create, they may be unavailable for the project/type" error on Create issue or Edit issue action in automation rule

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Automation rule might fail to update some fields while in the following scenarios:

  • Scenario 1: creating an issue using the Create Issue action in the automation rule
  • Scenario 2: editing an issue using the Edit Issue action in the automation rule
  • Scenario 3: creating/editing an issue via automation, however the value automation is trying to set it invalid for the project type (JSM)

Resulting in the following error message:

Unknown fields set during create, they may be unavailable for the project/type. Check your custom field configuration. Fields ignored -
 Time tracking (timetracking)


Diagnosis

  • Identify the rule execution in the audit log of the automation rule. Status should show "SOME ERRORS"
  • Click Show more to show the Action details of the executed rule. Review the block of operations to identify the field causing the errors. 
    • In the example below, the "Time tracking" field is the culprit


Cause

The field to be updated while:

  • Scenario 1: creating the issue doesn't exist on the Create Issue screen of the project Issue type
  • Scenario 2:
    • editing the issue doesn't exist on the Edit Issue screen of the project Issue type. 
    • or the custom field is only applicable to certain context (whether issue type or project level).

          As a result, the automation rule doesn't have access to update it, hence the error.

  • Scenario 3: This error can also be thrown for fields where the data supplied is invalid to the REST API endpoint.  One example of this is trying to supply a JSON formatted value in a manner the REST API is not expecting.  You can think of automation for Jira as using the REST API for changes to issues.   If the change can be made correctly via the REST API, then automation too should be able to make most of the same changes.  Testing the supplied values/format being supplied to the specific field by making a REST API call to the create or edit endpoint can help to identify the source of the error.  See JSM REST API Reference documentation and/or Jira Cloud REST API Reference for specific examples of JSON formatting for specific endpoints being called.

Solution

To resolve this:

  • Scenario 1: Add the field that's failing to the Create Issue screen of the project's issue type
  • Scenario 2: Add the field that's failing to the Edit Issue screen of the project's issue type. In case some applicable contexts are applied to specific issue types or projects, add the applicable context for other issue types/projects where you expect automation to have action upon those.
  • Scenario 3: If using JSON values for setting a field, confirm that you can set that specific field via the REST API.  Automation would need to use the same JSON formatting that a REST API call would use.

Helpful resources for configuring screens:




Last modified on Sep 4, 2024

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