Some fields are missing on the issue view for a few tickets even with correct field and screen configuration

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

   

Summary

Some issue fields are not visible on a few tickets even though the field is not hidden and the field is present on all the relevant screens.

Environment

Jira Service Management Cloud

Jira Cloud

Diagnosis

Customizing the field layout of your issue view allows you to add and customize the way fields appear on the issues. There are times when certain fields are not visible even when following the necessary configuration guidelines. When you try to find the field using the Find your field  tool, it passes all the checks but still, the field isn't visible on the issue view.

Please see the below documents for details about field layout configuration:

Screenshot for reference, using Find your field and no errors visible:

Cause

The field value is empty and the issue is under a status with the property jira.issue.editable set to false.

Please see documents below for details on the available properties:

See also feature request addressing this situation in JRACLOUD-83700 - Getting issue details... STATUS

Solution

There are two approaches to making the field appear on the issue view:

  • If you want to see these fields only for certain issues, then you can reopen these issues and set a value so that they appear on the issue view. Please note that a status change would trigger Customer Notifications to the reporter if the customer visible status change event is enabled in the customer notifications. You can Disable customer notifications temporarily while you perform these changes.
  • If you want to see these fields on all the issues whether there is a value set or not, even when an issue is closed, in that case, you need to remove the workflow property that restricts editing when an issue is closed. You can still remove necessary fields from the edit screen to have some kind of restriction on editing. Here are the steps to achieve this: 
    1. Edit the workflow associated with the issue type
      a. Navigate to Project Settings > Workflows > Edit 
      b. Select the status where the issue is not editable and choose Properties
      c. Delete the workflow property "jira.issue.editable" set to false

      d. Publish changes


NOTE:
If you want to keep editing restricted for closed issues, however, you have a certain field for which you want to set a value and make sure it appears on all the issues in the project. Here are some suggestions for that:

  • For existing issues, you can follow approach 2 to temporarily allow closed issues to be edited
  • Edit the issues in bulk to set a value
  • Revert the changes made to the workflow as part of approach 2 to keep the editing restricted for closed issues
  • For new issues, you can set a post function or automation rule to set a value for this field so that it's never empty and doesn't disappear from the screen when the issue is closed. 


Last modified on May 30, 2024

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