User Name and User Avatars are visible in JQL from 'Issue Panel' search but not in 'Advanced Search'
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary:
When you are passing JQL Query with a user field, say assignee = "Username", it is being changed to AAID "602XXXXXXXXXX" in the Advanced Issue search while Username and avatars are populated while searching the same user fields from the Issue panel search in the project.
Advanced Issue search :
Issue Panel search:
Environment:
NA
Diagnosis
NA
Cause
Our 'issue panel' search uses the new JQL editor, which shows simplified user values. We are still working on consolidating this new JQL editor with Advanced Issue Search and it will available soon.
This feature is in Jira bucket list for improvement so that users would get the same experience of search from both search features(Advanced Issue search and Issue panel Search). You can read about it on Roadmap page
Solution
Will be available soon. Find more about it under the "Consolidated Search in JIRA" section at Roadmap page.