After migrating from cloud to server, the Jira admin has lost access to some configuration settings.
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After the migration from cloud environment, Jira administrators are facing difficulties accessing certain links, such as troubleshooting and support tools, as well as scheduler details, among others. It's crucial to address this issue promptly to ensure the smooth operation of the system.
Environment
8.20.12
.
Diagnosis
Check which groups have ADMINISTER and SYSTEM_ADMIN permission:
select * from globalpermissionentry where PERMISSION='ADMINISTER';
select * from globalpermissionentry where PERMISSION='SYSTEM_ADMIN';
If any of the necessary permissions for Jira administration are missing, it could lead to the revocation of administrative privileges for the associated group or its members.
Solution
Please ensure that the missing permission is added to the globalpermissionentry by replacing the respective values <id>,<missing_permission> and <group_name> from the query above.
insert into globalpermissionentry (id, permission, group_id) values (<id>,'<missing_permission>','<group_name>');
Disclaimer: Always create a database backup prior to making any changes. Updating the database is not recommended and may result in unintended consequences. We advise against making any changes to the database without proper authorization and understanding of the potential impact on system functionality.