Automation Rule Failures with "Required Field" on Issue Creation via Advanced Roadmap Plans

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When attempting to create issues through Advanced Roadmap Plans in Jira, users may find that automation rules triggered by the "issue created" event fail to execute when there are "required fields" on the issue creation screen.

Environment

Jira cloud

Cause

Automation rules might trigger before the "required fields" are populated, causing rule failures due to incomplete issue data.

Solution

Add a "Re-fetch issue data" action after the "issue created" trigger in your automation rule. This action introduces a brief pause in the rule's execution, allowing it to revisit the issue after a moment to verify whether there have been any updates to the Required fields. Once this verification is complete, the rule will continue with its execution as intended.


Last modified on Aug 31, 2023

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