Cloning Issues in Jira: Preventing Notification to the Reporter.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When users intend to clone multiple issues, the cloned issues retain the reporter names from the original issue, causing unintended notifications to be sent to the reporters.
Environment
Jira Cloud
Cause
Presently, when an issue is cloned, notifications associated with the 'Issue Created (System)' event are automatically activated. Unfortunately, there is no current option to manage notifications specifically for cloned issues. However, there is an existing feature request submitted to our development teams, suggesting the addition of a dedicated notification event named 'Issue Cloned (System).' This enhancement would allow users to control notifications for cloned issues independently from the 'Issue Created (System)' events.
Link to Feature Request: Control notifications for Cloned issues-JRACLOUD-79792
Solution
Here is an Automation rule that you can use as a workaround:
Instead of using the 'Clone' feature, you can manually activate an automation rule each time you choose to clone an issue. This automation rule is designed to generate a new issue that replicates all the field data from the original issue that initiated the automation. The reporter's value is set to '{{initiator.name}}' which captures the name of the person triggering the rule. Additionally, an action is included to establish a link (indicating is cloned by) between the newly created issue and the original one.
This automation rule mimics the cloning process; however, as it designates the user who initiated the rule as the reporter, notifications will not be sent to the original reporter.