Unable to Save workflow due to "you cannot change the association between step and status" error response
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When trying to publish and save the workflow changes, an error message pops up stating that "you cannot change the association between step <step ID> and status <status name>".
Environment
Cloud
Diagnosis
- To Review the step ID and the association with respect to the status name as mentioned in the error message (In Text mode).
- Validate if the status is valid or corrupted.
- Try removing and adding back the affected status on the workflow.
Cause
One of the causes of the workflow not being able to publish even after removing and adding back the status would be that the workflow is corrupted.
Solution
- Go to the global settings by navigating to the cog icon(Top Right corner) > Issues > Workflows > search for the desired workflow, copy the workflow with a new name and re-associate with the issue type or the workflow scheme of the affected project to publish the changes and save them.
Last modified on Feb 21, 2024
Powered by Confluence and Scroll Viewport.