Gadget on shared Dashboard returns " could not be retrieved" error
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Some gadgets on a shared dashboard return the following error:
The filter configured for this gadget could not be retrieved. Please verify it is still valid on the issue navigator.
When the users click on the issue navigator link on the error message they receive another error message
Diagnosis
There are 3 layers of permissions a users needs to have to see relevant data returned on a shared Dashboard.
- The Dashboard need to be shared with the user.
- The Filters used in each gadget needs to be shared with the user
- The Projects used in the Filter needs to be available for the user.
Cause
Without all three of the permissions present the user viewing the dashboard will see no results returned by some or all of the gadgets.
Solution
Share the Dashboard with a user.
Navigate to the Dashboard and choose the ... action menu.
Choose Rename or share.
Make sure the end user has at least Viewers permission.
Share each filters used in the Dashboard with the user.
Navigate to the Filter and choose the Filter Details menu.
Make sure the user has at least Viewers permissions.
Add the user to the Project queried by the Filter.
Depending on the Product you use there are different ways to add users to projects, please follow the most appropriate one from below: