Getting the error "Reporter (username) does not have permission to create attachments in project" when creating issues by email

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When Jira is creating issues from incoming emails via the Jira Mail Handler, emails with attachments are created correctly, but the attachments are not added to the issue itself, and the following error message is placed as a comment on the ticket itself:

Reporter (aaa@mail.com) does not have permission to create attachments in project XXXX. 
Following attachments found in the email have been discarded:
aaa.xlsx
bbb.jpg

Environment

Any Jira Server/Data Center version from 5.0.0.

Diagnosis

Checking the debug incoming mail logs, we can observe the following output:

...Attachment was added to issue
...Reporter (aaa@mail.com) does not have permission to create attachments in project XXXX. Following attachments found in the email have been discarded:aaa.xlsx
...[10110]: Added comment 'Reporter (aaa@mail.com... 'by 'aaa@mail.com' to issue 'ISSUE-KEY'
...Deleting Message: <BAY145-W8265D25B144E7AAF00685EDE90@xxx.xxx>

The user has been granted ALL Project-level permissions for the relevant project, excluding Administer Projects. 

Cause

The project has a Default Issue Level Security set for all newly created issues. In this Issue Security Level, the reporter (the user account who sent the email) is denied access to the issue itself. This issue security level prevents the attachments from being created hence the error "Does not have permissions to create attachments", but does not prevent the issue from being created. (IssueLevelSecurity.jpg)

BUG REPORT: JRASERVER-32386 - Mail Handler unable to create attachments from email when reporter is not in the default issue security level

Resolution

To resolve this problem, edit the Issue Level Security to include the reporter, or remove the default Issue Level Security for all newly created issues. (IssueLevelSecurity.jpg)


Last modified on Feb 19, 2025

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