Can't save updates in advanced roadmaps (Jira Server and Data Center)

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Unable to commit changes editing issues on the Advanced Roadmaps Plan view.

Environment

Noticed on Jira 8.20.13.

Diagnosis

The error message "Changes couldn't be saved" will be displayed in the Review Changes area when attempting to commit changes.

On the left  warning sign, a popup message displays the following statement:

Issue could not be committed for unknown reasons
Please contact your administrator. You do not have permission to edit issues in this project.

On the atlassian-jira.log   you will see an error similar to the one below.

2023-02-01 15:48:49,779-0500 http-nio-8080-exec-84 ERROR userA 948x995125x1 gu2vjr 0.0.0.0 /rest/jpo/1.0/issues/commit [c.a.r.j.c.scenario.issue.IssueScenarioEntityCommitExceptionHandler] Exception when trying to commit issue: specific errors: {}. errorMessages: [You do not have permission to edit issues in this project.]


Cause

The Property Key jira.issue.editable  is set as False in the Workflow Status.

In the example below, the property is set on the In Progress status.

Solution

Remove the property Key jira.issue.editable from the Workflow Status property or set as True to re-enable modifications of issues in the specific status.

Last modified on Aug 12, 2024

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