Completed issues missing from Advanced Roadmap plans
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When using Jira with Advanced Roadmaps (previously known as Portfolio), some issues that are in a completed status are missing from the issue source and the scope, regardless of filters. Moving these issues to another status and refreshing the plan displays the issue.
Environment
All Jira and Advanced Roadmap versions
Cause
By default, Advanced Roadmaps checks the resolution date in the issue as validation that an issue is in a status that is mapped to the done category. See Working with Plans for more information. If the affected issue type in the issue source has a non-standard workflow that doesn't add a resolution when the issue is moved to the status that is mapped as done. Advanced Road Maps will not display the issue.
We do have an existing suggestion to fix this.
JPOSERVER-2442 - Getting issue details... STATUS
Workaround
Workaround 1:
Add a post-function to the workflow that updates the resolution field, if deemed appropriate.
Workaround 2:
As of version 2.22+, it's possible to view issues in statuses that are marked done without resolutions by enabling a dark feature:
- Navigate to the URL
<JIRA_BASE_URL>/secure/SiteDarkFeatures!default.jspa
(you must be a Jira administrator). Enable the following dark feature flag:
com.atlassian.portfolio.issueloading.includeUnresolvedCompleted
NOTE : This will not override the setting concerning Completed Issues in the settings of the plan ( Plan >> Configure >> Issue Sources )