Custom field values don't show in Advanced Roadmaps plans - Jira Data Center

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible


Problem

When viewing Advanced Roadmaps (Portfolio) plans with custom fields added to the view, those custom fields do not display any data in the plan. Custom field data can be seen if the issue is opened in the issue view page.

Diagnosis

Review the custom field's search template. Steps can be found in the Editing a custom field section of the Configuring a custom field page.

Cause

To be shown in Advanced Roadmaps plans (and in issue searches), custom fields need to be searchable. Custom fields that are configured as non-searchable won't be displayed in any JQL search results or in any functionalities that rely on JQL (Agile boards, Advanced Roadmaps, etc.).

Note that custom and plugin-provided search templates such as "Date/time range searcher (statistics by day)" are not supported and will also cause fields to not show values.

Resolution

Use the supported default date search template version:

  • Date Range Picker for Date Picker type field.
  • Date Time Range Picker for Date Time Picker type field.

Reconfigure custom fields to be searchable by selecting the proper Search Template in the custom field’s edit page (Actions  > Edit). Documentation link below:

If you still don't see the data after that, you might also need to re-index the project or run a full re-index depending on the scope of your data source.

Last modified on Dec 5, 2024

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