Issues are not showing under child issues panel
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Some Jira users are not able to view issues in the Child Issues panel, which is the panel used to show which Jira issues are linked under a parent issue as per the Hierarchy Level configuration:
Environment
Jira Software on Server/Data Center on any version from 8.15.0 (which is bundled with Advanced Roadmaps for Jira).
Diagnosis
Verify if the issues link table and the link type are proper or not using the below queries.
SELECT ls.id,ls."source",ls."key" as "source key",ld."destination" as "destination",ld."key" as "destination key" from (SELECT il.id, linktype, il."source", il.destination, il."sequence" ,CONCAT(p.pkey ,'-' ,ji.issuenum) as "key" FROM public.issuelink il join jiraissue ji on il."source"= ji.id join project p on ji.project= p.id where linktype =(select id from issuelinktype where "pstyle" = 'jira_jpos_parent_child')) ls JOIN (SELECT il.id, linktype, il."source", il.destination, il."sequence" ,CONCAT(p.pkey ,'-' ,ji.issuenum) as "key" FROM public.issuelink il join jiraissue ji on ji.id = il.destination join project p on ji.project= p.id where linktype =(select id from issuelinktype where "pstyle" = 'jira_jpos_parent_child')) ld on ls.id = ld.id
Verify that there is no workflow change on the impacted tickets
SELECT CONCAT(p.pkey ,'-' ,i.issuenum),p.pname, cg.ID, cg.issueid, au.lower_user_name, cg.AUTHOR, cg.CREATED, ci.FIELDTYPE, ci.FIELD, ci.OLDVALUE, ci.OLDSTRING, ci.NEWVALUE, ci.NEWSTRING FROM changegroup cg inner join jiraissue i on cg.issueid = i.id inner join project p on i.project = p.id inner join changeitem ci on ci.groupid = cg.id inner join app_user au on cg.author = au.user_key WHERE cg.issueid in (select il.destination from issuelink il join jiraissue ji on ji.id = il.destination join project p on ji.project = p.id and linktype=10300 ) and ci.FIELD='Workflow' order by 1,3,4;
If the above 2 queries output looks good then, Please proceed with checking the output of the below query, because it should return only the parent_link field only. Since in some cases, it returns extra field(s), which could lead to issue observed:
SELECT id, cfkey, customfieldtypekey, customfieldsearcherkey, cfname, description, defaultvalue, fieldtype, project, issuetype, issueswithvalue, lastvalueupdate FROM public.customfield where customfieldtypekey like '%com.atlassian.jpo:jpo-custom-field-parent%'
- If the results of above query returns more fields along with the parent_link field as observed in below results. Ensure to keep only parent_link field:
Cause
The behavior is observed due to data integrity, since the query is supposed to return the Parent Link field
Solution
Run the below query
SELECT id, cfkey, customfieldtypekey, customfieldsearcherkey, cfname, description, defaultvalue, fieldtype, project, issuetype, issueswithvalue, lastvalueupdate FROM customfield where customfieldtypekey like '%com.atlassian.jpo:jpo-custom-field-parent%'
If it returns any other field extra other than the Parent_link field then:
Make sure the "extra field" (other than Parent_link) field is not being used anywhere in your instance then, you can delete it by following the below sequence steps ( Take a DB backup before deleting it)
Stop Jira
Take a database backup
Delete the extra field using the following query:
delete FROM customfield where cfname = 'Extra field name from above query' and customfieldtypekey = 'com.atlassian.jpo:jpo-custom-field-parent'
- Start Jira and either reindex only the impacted project or if many projects had similar issue run a full reindex.
- Please take into consideration that it is possible that the changes won't reflect immediately and will be seen after few minutes after a successful reindexing