Some Jira issues are created without a priority
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Some Jira issues are created without the priority field set. When opening the issue in the View Issue screen, the priority field is missing (which is expected when a field is empty):
The purpose of this KB article is to describe a scenario where Jira issues might be created without a priority field set.
Environment
Jira Server/Data Center 8.20.0 and any higher version
Diagnosis
- Check how the issues without priority were created. If these issues were created from an Advanced Roadmap Plan as illustrated in the screenshot below, then this KB article might be relevant:
- Go to ⚙ > Issues > Priority Schemes, click on Edit next to the Priority Scheme associated to the project the impacted issues belong to, and look at the default priority value. If it is set to None, and if the impacted issues were created from a Roadmap Plan, then this KB article is relevant:
Cause
This behavior is due to the combination of 2 factors:
- the Priority Scheme associated to the project the issue belongs to had the Default priority set to None
- the issue was created via a Roadmap Plan
When issues are created via other ways, for example by using the Jira Create button from the Top bar menu, or by using the Customer Portal in Service Management projects, the default priority will be set: the issue is automatically created by using the priority in the middle of the list of priorities from the Priority Scheme (the blocker priority, if we take the Priority Scheme from the screenshot above):
The difference between the way Jira/JSM and Advanced Roadmap handle the "none" default priority is currently tracked in the Feature Request below:
JPOSERVER-9505 - Getting issue details... STATUS
Solution
To prevent issues from being created without a priority from the Advanced Roadmap view, edit the Priority Scheme and make sure that the Default Priority is not set to None, but to a valid priority.