Some resolved Jira issues are missing from Advanced Roadmaps programs
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The purpose of this article is to describe a scenario where some resolved issues are missing from an Advanced Roadmaps Program, while it is showing in one of the Plans the Program is connected to.
Let's take the example of the issue SCRUM-16 which is resolved:
- This issue is showing in the Plan:
- However, it's missing from the Program the Plan is connected to:
Environment
Jira Software on Server/Data Center on any version from 8.15.0.
Diagnosis
- Open the issue that is missing from the Program in the View issue page and check the resolution date. In the example below, we can see that the issue was resolved back in 2021:
- In the Program scope view, click on More and check the Completion Date filter. If this filter is using the default value which is "Completed issues within the last 30 days" (as illustrated below), and if the issue was resolved more than 30 days ago, this article is relevant:
Cause
Similarly to the Plan's exclusion rules, Programs also have filters which allow to hide issues. One of the filter is called Completion date and filters issues that were resolved before a certain date. By default, if no filter is manually selected or changed, all Programs will be using the default "Completed issues within the last 30 days" value for this filter. If any issue was resolved more than 30 days ago, it will be missing from the Program (from both the Scope and the Schedule views).
Solution
Change the Completion date filter of the Program to include issues resolved up to a certain date of your choice.