The value of date picker custom field is not shown on Advanced Roadmaps Plan
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The value of a date picker custom field is not shown on Advanced Roadmaps Plan, even though the custom field has value shown on view issue page.
Symptoms
On the view issue page, we confirm that the custom field has value.
Full re-indexing the issue does not resolve the problem.
Cause
The affected date picker custom field is using a Search Template other than Date Range picker (Jira's default search template for date picker field). There are often cases where the Search template is set to a third party app's template such as JMCF.
Resolution
1. Navigate to Jira Administration ⚙ > Issues > Custom fields. Look for the affected custom field, click on the three dots at the end, then choose the Edit option.
2. Choose Date Range picker for the Search Template.
3. Run a full re-index of Jira.