Unable to commit creation of new issue from Advanced Roadmaps

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

User may be unable to commit the creation of new issues when done through the Advanced Roadmaps (formerly Portfolio) Plan view. Below is one of the potential causes related to Priority configuration.

Environment

Noticed on Jira 8.18.1 and Advanced Roadmaps 3.29.8.

Diagnosis

On the Review Changes area when attempting to commit changes, you may see "Not in plan" for the priority field:

When you try to save changes you get an error message on the bottom left:

Changes couldn't be saved

On atlassian-jira.log  you will see an error similar to the one below.

2021-08-05 22:07:53,602-0700 https-jsse-nio-443-exec-35 url: /rest/jpo/1.0/issues/commit; user: useruser WARN useruser 1327x970117x1 y11kfi 10.21.16.102 /rest/jpo/1.0/issues/commit [c.a.r.j.env.issues.JiraIssueService] Could not create issue. Validation-errors: {priority=The priority selected is invalid.}
2021-08-05 22:07:53,603-0700 https-jsse-nio-443-exec-35 url: /rest/jpo/1.0/issues/commit; user: useruser WARN useruser 1327x970117x1 y11kfi 10.21.16.102 /rest/jpo/1.0/issues/commit [c.a.r.j.c.scenario.common.BaseScenarioEntityCommitService] Error in commit operation.
com.atlassian.rm.jpo.env.issues.EnvironmentIssueCreateException: Specific error details: {priority=The priority selected is invalid.}
        at com.atlassian.rm.jpo.env.issues.JiraIssueService.createIssue(JiraIssueService.java:728)
        at com.atlassian.rm.jpo.env.issues.JiraIssueService.createIssue(JiraIssueService.java:164)
        at com.atlassian.rm.jpo.core.scenario.issue.ScenarioIssueCreateAction.performApiOperation(ScenarioIssueCreateAction.java:88)
        at com.atlassian.rm.jpo.core.scenario.issue.ScenarioIssueModificationAction.perform(ScenarioIssueModificationAction.java:317)
        at com.atlassian.rm.common.persistence.transaction.Registry.run(Registry.java:35)
        at com.atlassian.rm.jpo.core.scenario.issue.ScenarioIssueCommitService.add(ScenarioIssueCommitService.java:137)
        at com.atlassian.rm.jpo.core.scenario.issue.ScenarioIssueCommitService.add(ScenarioIssueCommitService.java:47)
        at com.atlassian.rm.jpo.core.scenario.common.BaseScenarioEntityCommitService.addInternal(BaseScenarioEntityCommitService.java:349)
... it goes on..

Cause

The cause is still unknown. It could be related to data corruption on Advanced Roadmaps. We have reports of it happening after Jira upgrade but it could not be reproduced.

Solution

The solution found was to associate the project with a Priority Scheme that had a default value which is not the case for Jira's default Default priority scheme.

Once the change was made the proper priority starts showing on the Review Changes screen and you should be able to commit the creation.


Creating issues is supposed to work even if you have Default priority scheme associated - we switch from it to bypass this problem. You may try switching back to the Default priority scheme afterwards.

Last modified on Aug 12, 2021

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