Bamboo doesn't start up: Your build of Bamboo is too old to work with the data in your Bamboo home directory

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server and Data Center Only. This article only applies to Atlassian products on the server and data center platforms.

Summary

Bamboo server fails to start. This might be after an upgrade. Bamboo server logs contain this:

...
ERROR [localhost-startStop-1] [DefaultAtlassianBootstrapManager] Home is not configured properly: 
com.atlassian.config.ConfigurationException: Your build of Bamboo (80009) is too old to work with the data in your Bamboo home directory (/data/atlassian/bamboo), which comes from build number 80010
...

Cause

The <bamboo-install> directory of version 8.0.1 (build 80009) is pointing to a <bamboo-home> directory which is on a newer version, 8.0.2 (build 80010).

Solution

If you have recently upgraded, please double-check if Bamboo is not being started using the old install folder rather than the new version's one.

You can also try installing a new instance that matches the version on your home directory, and point the newly installed <bamboo-install>/atlassian-bamboo/WEB-INF/classes/bamboo-init.properties to the current <bamboo-home>.

Please note

The above example is related to Bamboo versions 8.0.2 and 8.0.1. However, this can be applied to any version mismatch that Bamboo complains about. The only thing is that you will need to use the correct Bamboo version (version 8.0.2 for this specific case) of <bamboo-install> to point to the <bamboo-home>.

Last modified on Oct 28, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.