Bamboo search bar is not working properly

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The search bar for bamboo is not working as expected even with the correct access/permissions for the projects and plans.

Therefore, users can only search for some projects or plans. The rest of the plans/projects do not show up on the search bar.

Environment

Bamboo 7+ running on Linux

Diagnosis

Some Bamboo files may have the incorrect permission for the user that is running Bamboo.

Cause

It can be caused by manually moving or editing Bamboo files inside the Bamboo-home or Bamboo-installation folders.

Solution

Delete the contents of the following folders and restart Bamboo:

/bamboo-home/caches/
/bamboo-home/temp/
/bamboo-home/index/
/bamboo-home/jms-store/

Fix the permission to your bamboo-installation and bamboo-home folder:

chown -R bamboo user:bamboo-group <bamboo-installation-folder>
chown -R bamboo user:bamboo-group <bamboo-home-folder> 

bamboo user: Is the OS user you're using to start Bamboo instance
bamboo-group: Is the group of the user running your Bamboo instance

Please visit Fixing Bamboo files and folder permission for Linux installations for more details.

Re-index Bamboo's build results data (Not required but recommended, since search bar works with queries):

  1. Click the cog icon in the Bamboo header at the right top corner and choose Overview
  2. Click Indexing in the left navigation column, under 'System'
  3. Click Perform a full reindex


Last modified on Feb 21, 2022

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