Bamboo Windows service doesn't start due to a logon failure

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Bamboo doesn't start as a service on Windows and throws "Error 1069: The service didn't start due to a logon failure".

Environment

Bamboo running on Windows and installed as service.

Diagnosis

The following error is thrown by the Service Manager when attempting to start the Bamboo service:

Error 1069: The service didn't start due to a logon failure.

Cause

The issue usually occurs if you:

  • Provided a wrong account password when configuring your service.
  • Changed the password of the account used by the service, and have not updated this information in the service.
  • The account's password expired automatically.
  • A System Administrator has changed the password.

Solution

Double-check if the password set for the service is correct and update it accordingly.

Editing the account used by a service application

  1. Open the Windows Service Manager (you can access it from Windows Control Panel > Administrative Tools or the Start menu when you type services).
  2. Find your service (e.g., Atlassian Bamboo Bamboo) and double-click it to open its properties (or right-click it and select Properties).
  3. You can edit the service account on the Log On tab. Make sure to provide the correct password for the selected account. If the Local System account radio button is selected, change it to This account, select an account and provide the correct password.


Please follow the instructions from Running Bamboo as a Windows service as the local user when installing Bamboo as a service.

For more information on the error and further troubleshooting, please check this external page: Troubleshooting Error 1069: The service did not start due to a logon failure

Last modified on Jul 1, 2022

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