Rerun Build not appearing in Agent's Recent build history
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
If a build fails, is rerun, and is dispatched to a different agent, the build will appear to have disappeared from the Recent Build list.
Diagnosis
Diagnostic Steps
Please verify the
QUEUE_ID
of the Agent where you expect the Build to be listed from theQUEUE
table in the Bamboo database:SELECT QUEUE_ID FROM QUEUE WHERE TITLE = '<agent-name>';
Please review the Build Result Summary of the missing Build
For example, if the Build has Build KeyPROJ-PLAN
, and Job keys ofPROJ-PLAN-JOB1
,PROJ-PLAN-JOB2
, etc, and was Build number 10:SELECT BUILD_AGENT_ID FROM BUILDRESULTSUMMARY WHERE BUILD_KEY LIKE 'PROJ-PLAN%' AND BUILD_NUMBER = 10;
- Compare the output of queries 1 and 2. If they are different, this article applies.
Cause
The BUILD_AGENT_ID
column of BUILDRESULTSUMMARY
, which populates the Recent Builds list, is overwritten on each rerun of a given build.
Resolution
Using the output of Diagnostic step 2, you can run the following database query to find the Agent where the Build will be listed:
SELECT TITLE
FROM QUEUE
WHERE QUEUE_ID = '<agent-id>';
Please check that agent's Build History for the Build.