Tasks do not run on agents due to Plugin availability errors

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

When using Remote agents, you may occasionally see Tasks fail with errors such as:

Error occurred while executing the build for <build name ###> (PROJ-PLAN-JOB-###) : Plugin <plugin key> not available

or:

Could not execute task '<task name>' no Plugin with key '<plugin key>' is installed.

Diagnosis

If your <bamboo-agent-home>/atlassian-bamboo-agent.log has multiple JVM IDs running at the same time, this article applies. For example:

INFO   | jvm 1    | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,438 INFO
INFO   | jvm 1    | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,439 INFO
INFO   | jvm 56   | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,436 INFO
INFO   | jvm 1    | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,532 INFO
INFO   | jvm 1    | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,533 INFO
INFO   | jvm 56   | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,531 INFO
INFO   | jvm 56   | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,629 INFO

Cause

This is often caused by multiple Remote agents sharing the same Bamboo Agent Home directory. When new agents start up, the plugin cache within the agent home directory is cleared and reloaded from the server, which can cause these plugins to not be found by one of the agent processes.

Resolution

Please ensure that each Remote Agent has its own Home directory.

Create new Bamboo Agent Home directories so that every agent on the server has its own Home directory:


Last modified on Nov 2, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.