Bitbucket Server Automated Support Request Fails to Lodge a Support Ticket

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Symptoms

Support request lodged via Administration -> Atlassian Support Tools -> Support Request does not create a support ticket at https://support.atlassian.com

The following exception is reported in atlassian-bitbucket-mail.log:

2013-05-15 12:15:21,213 ERROR [MailServiceSender:thread-1] devops 734x2812x1 1rdqn94 10.186.41.147,127.0.0.1 "POST /plugins/servlet/stp/view/create-support-request/execute HTTP/1.1" bitbucket.mail-log Message not sent: Mail sending failed; recipient: bitbucket-autosupportrequests@atlassian.com; subject: TEsting support email capability
org.springframework.mail.MailSendException: Failed messages: com.sun.mail.smtp.SMTPSendFailedException: 552 5.3.4 Error: message file too big

Cause

This is due to a 25MB log file limit put in place by most email servers, that does not allow files larger than this size to be sent via email.

Resolution

Ensure the "Limit File Sizes?" option is checked when sending log files larger than 25MB, as this will truncate the files and send them successfully. Alternatively, if you need to send out the entire log file, manually upload the log files directly to the Support ticket via https://support.atlassian.com

But, if the overall zip is still greater than what your email server will send, it will still fail to send the ticket.

Last modified on Jun 16, 2017

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