Manage add-ons - An unexpected error has occurred. Please refer to the logs for more information.
Problem
- You cannot access the Universal Plugin Manager from "Administration -> Manage add-ons" link.
You may receive an error and see the following screen:
An unexpected error has occurred. Please refer to the logs for more information.
Cause
There are a few potential causes:
1) Configuration
a. The most common problem is that your server base URL does not match the actual URL of the site.
b. If you are running Bitbucket Server prior to 5.0:
- Incorrect or missing proxy settings in your server.xml when accessing Bitbucket Server behind a proxy
- After Bitbucket Server 5.0
server.xml
is not configurable anymore and you need to make a manual migration using these instructions: Migrate server.xml customizations to bitbucket.properties
c. Incorrect plugin loading order causing UPM to fail to initialize properly when Bitbucket Server is started.
2) UPM bug
3) Proxy configuration
Try to bypass the apache reverse proxy. If the issue does not occur when the proxy is not in place, we can determine that the proxy setting is the cause of the issue.
4) New security baselines on Bitbucket server
5) Incompatible plugin
Resolution
1) Configuration
In matching order for the above listed causes:
a. Your server base URL needs to match the URL that you are using to access Bitbucket Server. To change this setting, follow the Specify the Bitbucket base URL document.
b. The proxy information must be properly configured. Please review Proxy and secure Bitbucket and make sure you include the appropriate proxy information for the connector. Notice that for Bitbucket Server 5.0+, you will need to Migrate server.xml customizations to bitbucket.properties.
c. To correct the plugin loading order, follow the steps below:
- Shut Bitbucket Server down
- Backup
<BITBUCKET_HOME>/plugins
directory - Remove the following directories. They will be rebuilt when Bitbucket Server starts again.
<BITBUCKET_HOME>/plugins/.bundled-plugins/
<BITBUCKET_HOME>/plugins/.osgi-cache/
Restart Bitbucket Server.
Upon starting up, Bitbucket Server will re-extract the required plugins from
<BITBUCKET_INSTALL>/atlassian-bitbucket/WEB-INF/classes/bundled-plugins.zip
and rebuild those plugin directories.
2) UPM bug
Upgrade your UPM.
3) Proxy configuration
Consider involving the network team to understand what is blocking/dropping the connection. We have also seen this happen due to how apache doesn't handle JavaScript very well and it requires a dependency package to also be installed. You may compare both the proxy config with the one in the examples provided in the documentation.
4) New security baselines on Bitbucket server
Please read through:
5) Please check the plugin is compatible with your Bitbucket instance on the https://marketplace.atlassian.com